1032 挖掘机技术哪家强 (20 分)java

39次阅读

共计 1020 个字符,预计需要花费 3 分钟才能阅读完成。

为了用事实说明挖掘机技术到底哪家强,PAT 组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:
输入在第 1 行给出不超过 10^​5​​ 的正整数 N,即参赛人数。随后 N 行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从 1 开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:
在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。输入样例:
63 652 801 1002 703 403 0
输出样例:
2 150
Think 这里存储我用的数组,学校编号为数组下标,分数为对应的下标值。注意校编号从 1 开始。
code

import java.io.*;

public class 挖掘机技术哪家强 {

public static void main(String[] args) throws IOException {
StreamTokenizer in = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
in.nextToken();
int n = (int) in.nval,max = 0,len,sch = 0;
int[] score = new int[n];
while(0 < n–) {
in.nextToken();
int schoo = (int) in.nval;
in.nextToken();
int sco = (int) in.nval;
score[schoo] += sco;
}
len = score.length;
for(int i = 1 ; i < len ; i++) {
if(score[i] > max) {
max = score[i];
sch = i;
}
}
System.out.print(sch + ” ” + max);
}
}
遗憾的是 java 代码跑不通 pta,所以用 C ++ 代码吧,测试通过了
#include<iostream>
#include<cstdio>
using namespace std;
int a[100001]={0};
int main() {
int n,bianhao,score,max=0,j;
cin>>n;
while(n–){
cin>>bianhao>>score;
a[bianhao] += score;
}
for(int i=0;i<100000;i++) {
if(a[i]>max) {
max = a[i];
j = i;
}
}
cout<<j<<” “<<max; return 0;
}

正文完
 0